EyeTV Lite



Important: EyeTV Lite must already be installed in order to use these updates.

System Requirements

EyeTV Lite 1.3.7 is a Universal application. It requires an Intel Macintosh computer with built-in USB 2.0 ports and Mac OS X 10.5.8 or later. We recommend Mac OS X 10.7.3 with all software and security updates installed.

Snow Leopard Compatibility

EyeTV Lite 1.3.7 is fully compatible with Snow Leopard.


Older Versions


Download EyeTV Lite 1.3.3 now

Read Me File - English
Read Me File - Japanese


Download EyeTV Lite 1.1 now

EyeTV Lite is an Universal application. It requires a Macintosh computer with PowerPC G4 (500MHz or faster), PowerPC G5 or Intel Core processor, and Mac OS X 10.4 (Tiger) or later.

Read Me File


Support for products bundled with EyeTV Lite is provided by the manufacturer.