EyeTV 2

Important:

EyeTV 2 is no longer sold and technical support for this product is no longer available. You must have an EyeTV 2 activation key in order to use these updates. Please note that the activation keys for older 1.8.x versions will not work with EyeTV 2 updates.

EyeTV 2.5.3 is a Universal application. It requires a Macintosh computer with PowerPC G4 (500MHz or faster), PowerPC G5 or Intel Core processor, and Mac OS X 10.4.11 (Tiger) or later. We recommend Mac OS X 10.5.4 Leopard with all software and security updates installed.

Read Me File - English
Read Me File - Japanese


Older Versions


Download EyeTV 2.5.2 now

Required: Macintosh computer with PowerPC G4 (500MHz or faster), PowerPC G5 or Intel Core processor, and Mac OS X 10.4 (Tiger) or later.

Read Me File - English
Read Me File - Japanese


Download EyeTV 2.5.1 now

Required: Macintosh computer with PowerPC G4 (500MHz or faster), PowerPC G5 or Intel Core processor, and Mac OS X 10.4 (Tiger) or later.

Read Me File - English
Read Me File - Japanese


Download EyeTV 2.5 now

Required: Macintosh computer with PowerPC G4 (500MHz or faster), PowerPC G5 or Intel Core processor, and Mac OS X 10.4 (Tiger) or later. We recommend Mac OS X 10.4.10 with all software and security updates installed.

Read Me File - English
Read Me File - Japanese